Email submissions

Incident Report for Ouriginal

Resolved

This incident has been resolved.
Posted Sep 19, 2022 - 08:38 UTC

Monitoring

The problem with email submissions has been solved. All email submissions sent during the incident are stored in our system and will be analyzed shortly.
Posted Sep 19, 2022 - 07:53 UTC

Update

We are continuing to investigate this issue.
Posted Sep 19, 2022 - 07:25 UTC

Investigating

We are currently investigating problems with Email submissions
Next update 10am (CEST)
Posted Sep 19, 2022 - 07:25 UTC
This incident affected: Email submissions.