Delays in report/confirmation emails

Incident Report for Ouriginal

Resolved

This incident has been resolved.
Posted Apr 08, 2022 - 15:34 UTC

Monitoring

The problem is solved and all submissions sent via email will be handled.
Posted Apr 08, 2022 - 14:58 UTC

Investigating

We are currently investigating the issue.
Only affects email submissions.
Posted Apr 08, 2022 - 14:40 UTC
This incident affected: Email submissions.