Password reset URSA
Incident Report for Ouriginal
Resolved
Password reset is now working again
Posted Sep 22, 2021 - 15:01 UTC
Investigating
Password reset functionality is broken, we are investigating and will update in 2 h.
Posted Sep 22, 2021 - 14:32 UTC